About Me

Algorithmique Licence_1 Évaluation-5

Testez vos connaissances en algorithme ici


Ce processus a été mise en place pour aider les étudiants de UVCI dans leurs révisions, aussi pour mieux comprendre et affronter le système UVCI Sans plus tarder , Je vous invite donc à passer ce test.

Voulez-vous commencer le devoir ?

Le devoir a un temps de 55min
Veuillez bien réviser votre léçon avant de commencer






Soit un tableau T ci-dessous ( 2pts )

8

15

-9

14

-8

2

0

1

       

  Quel est la taille du tableau :


La réponse est :


La réponse correcte est : 8




2- Soit un tableau T ci-dessous ( 2pts )


8

15

-9

14

-8

2

0

1

5

9


cal ← 0

Pour I ← 1 A 10 Faire

         cal ← cal  + T[6]

FinPour


Quel sera le résultat obtenu de cal :

La réponse est :


La réponse est correcte : 20




3- Soit un tableau T ci-dessous ( 2pts )


8

15

-9

14

-8

2

0

1

5

9



cal ← 0

Pour I ← 1 A 10 Faire

         cal ← T[I]

FinPour

Afficher  cal

Quel sera le résultat obtenu de cal :

La réponse est :


La réponse correcte est : 9




4 - Soit un tableau T ci-dessous

2

1

2

2

3

- 1

1

-2

2

 

resul ← 1

Pour I← 1 A 3 Faire

   Pour J← 1 A 3 Faire

      Si I = J Alors

           resul ← resul  *  T[I,J]

       Finsi

    FinPour

FinPour

    Afficher  resul


Quel sera le résultat obtenu de resul :

La réponse est :


La réponse correcte est : 12




5 - Soit un tableau T ci-dessous ( 2pts )

2

1

2

2

3

- 1

1

-2

2


resul ← 1

Pour I← 1 A 3 Faire

   Pour J ← 1 A 3 Faire

        T[I,J]  ← resul  

          resul  ← resul  +2

    FinPour

FinPour

    Afficher   T[2,3] 


Quel sera le résultat obtenu de  T[2,3]   :


La réponse est T[2,3] =


La réponse correcte est : 11




6 - Soit un tableau T ci-dessous ( 2pts )

12

4

3

4

-9

11

3

2

20

6

5

13


Quel est la taille du tableau :
La réponse est : Ligne =     ; Colonne =  


Consigne : Pour voir la correction de cette question veuillez survoler les cases .




7 - Soit un tableau T ci-dessous (2pts)

8

15

-9

14

-8

2

0

1

5

15



cal ← 0

Pour I← 1 A 10 Faire

          T[I] ← cal

         cal ← cal  + 1

FinPour

  Afficher T[10], cal


Quel sera le résultat obtenu de cal,T[10] :



La réponse est : cal =     ; T[0] =



Consigne : Pour voir la correction de cette question veuillez survoler les cases .




8 - Soit un tableau T ci-dessous

8

15

-9

14

-8

2

0

1

5

9



cal ← 0

Pour I← 1 A 10 Faire

         cal ← cal  + T[I]

FinPour


Quel sera le résultat obtenu de cal :

La réponse est :


la reponse correcte est : 37




9 - Soit un tableau T ci-dessous (2pts)

2

1

2

2

3

- 1

1

-2

2

 

resul ← 0

Pour I← 1 A 3 Faire

   Pour J← 1 A 3 Faire

      Si resul < T[I,J] Alors

           Resul ← T[I,J]

       Finsi

    FinPour

FinPour

Afficher Resul

   

Quel sera le résultat obtenu Resul :

La réponse est :  Resul =



La réponse correcte est : 3




 10 - Soit un tableau T ci-dessous (2pts)

12

4

3

4

-9

11

3

2

20

 

cal ← 0

Pour I← 1 A 3 Faire

   Pour J← 1 A 3 Faire

         cal ← T[I,J]

    FinPour

FinPour

    Afficher  cal


Quel sera le résultat obtenu de cal :


Le résultat est cal est :



La réponse correcte est : 20




Enregistrer un commentaire

0 Commentaires